# CVE-2014-5252: OpenStack Identity (Keystone) UUID v2 tokens does not expire with revocation events

> Authenticated users can bypass token expiration in OpenStack Keystone V3 API by updating issued_at values, retaining unauthorized access.

- **Severity:** Medium 4.9 (`AV:N/AC:M/Au:S/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-5252, GHSA-v8fq-gq9j-3v7h, PYSEC-2014-108, UBUNTU-CVE-2014-5252

## What is CVE-2014-5252?

CVE-2014-5252 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 25 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The V3 API in OpenStack Identity (Keystone) 2014.1.x before 2014.1.2.1 and Juno before Juno-3 updates the issued_at value for UUID v2 tokens, which allows remote authenticated users to bypass the token expiration and retain access via a verification (1) GET or (2) HEAD request to v3/auth/tokens/.

Weakness: CWE-255

## Which versions are affected by CVE-2014-5252?

3 open source packages ship an affected version, including keystone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |

Products: Canonical Ubuntu Linux, Openstack Keystone.

## How do I fix CVE-2014-5252?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2014-5252 being exploited?

There is no known exploitation of CVE-2014-5252 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5252 and fix it if it is affected.

What it is: CVE-2014-5252 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 25 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-5252 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5252/ (Markdown: https://insights.sbomify.com/CVE-2014-5252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5252
- OSV: https://osv.dev/vulnerability/CVE-2014-5252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5252/
Summaries are generated and may contain mistakes; the official description above is the record.
