CVE-2014-5274 phpMyAdmin cross-site scripting vulnerability in crafted view name
Authenticated users can inject arbitrary scripts via crafted view names in phpMyAdmin, potentially compromising other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-5274?
CVE-2014-5274 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 22 Aug 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.
Weakness: CWE-79
Which versions are affected by CVE-2014-5274?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.3 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.3 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.7.1 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.7.1 |
Products include Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2014-5274?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.1.14.3 or 4.2.7.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-5274 being exploited?
There is no known exploitation of CVE-2014-5274 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-5274, GHSA-q586-xpwr-jc3j, UBUNTU-CVE-2014-5274.