# CVE-2014-5277: Man-in-the-Middle (MitM)

> Man-in-the-middle attackers can downgrade Docker registry connections to HTTP, exposing authentication credentials and image data.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-5277, GHSA-8w94-cf6g-c8mg, GO-2022-0636, PYSEC-2014-80, UBUNTU-CVE-2014-5277

## What is CVE-2014-5277?

CVE-2014-5277 is a medium-severity vulnerability in n/a, published on 17 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docker before 1.3.1 and docker-py before 0.5.3 fall back to HTTP when the HTTPS connection to the registry fails, which allows man-in-the-middle attackers to conduct downgrade attacks and obtain authentication and image data by leveraging a network position between the client and the registry to block HTTPS traffic.

Weakness: CWE-17

## Which versions are affected by CVE-2014-5277?

4 open source packages ship an affected version, including github.com/docker/docker and docker-py. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 1.3.1 |
| `github.com/docker/docker` | Go | All versions | 1.3.1 |
| `github.com/docker/docker` | Go | All versions | 1.3.1 |
| `docker-py` | PyPI | All versions | 0.5.3 |

Products: Docker Docker, Docker Docker-Py.

## How do I fix CVE-2014-5277?

Upgrade github.com/docker/docker to 1.3.1 or later.

## Is CVE-2014-5277 being exploited?

There is no known exploitation of CVE-2014-5277 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-9357](https://insights.sbomify.com/CVE-2014-9357/): Arbitrary Code Execution (critical 10.0)
- [CVE-2020-14298](https://insights.sbomify.com/CVE-2020-14298/): Privilege escalation in Docker (high 8.8)
- [CVE-2020-14300](https://insights.sbomify.com/CVE-2020-14300/): Privilege escalation in Docker (high 8.8)
- [CVE-2018-15514](https://insights.sbomify.com/CVE-2018-15514/): Deserialization in n/a (high 8.8)
- [CVE-2014-9356](https://insights.sbomify.com/CVE-2014-9356/): Path Traversal in Docker (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5277 and fix it if it is affected.

What it is: CVE-2014-5277 is a medium-severity vulnerability in n/a, published on 17 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-5277 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.1
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.1
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.1
- docker-py (PyPI): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5277/ (Markdown: https://insights.sbomify.com/CVE-2014-5277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5277
- OSV: https://osv.dev/vulnerability/CVE-2014-5277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5277/
Summaries are generated and may contain mistakes; the official description above is the record.
