# CVE-2014-5356: OpenStack Glance improper validation of the image_size_cap configuration option

> Authenticated users can cause disk exhaustion and denial of service by uploading large images when image size limits are not properly enforced.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-5356, GHSA-479j-jf2p-38pg, PYSEC-2026-810, RHSA-2014:1337, RHSA-2014:1338, RHSA-2014:1685, UBUNTU-CVE-2014-5356, USN-2322-1

## What is CVE-2014-5356?

CVE-2014-5356 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 25 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Image Registry and Delivery Service (Glance) before 2013.2.4, 2014.x before 2014.1.3, and Juno before Juno-3, when using the V2 API, does not properly enforce the image_size_cap configuration option, which allows remote authenticated users to cause a denial of service (disk consumption) by uploading a large image.

Weakness: CWE-264

## Which versions are affected by CVE-2014-5356?

3 open source packages ship an affected version, including glance. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `openstack-glance` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-glance-doc` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `python-glance` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.4-1.el6ost |
| `openstack-glance` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.2-5.el6ost |
| `openstack-glance-doc` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.2-5.el6ost |
| `python-glance` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.2-5.el6ost |
| `openstack-glance` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.2-3.el7ost |
| `openstack-glance-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.2-3.el7ost |
| `python-glance` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.2-3.el7ost |

Products: Canonical Ubuntu Linux, Openstack Image Registry and Delivery Service \(Glance\).

## How do I fix CVE-2014-5356?

Upgrade glance to 11.0.0a0 or later.

## Is CVE-2014-5356 being exploited?

There is no known exploitation of CVE-2014-5356 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5356 and fix it if it is affected.

What it is: CVE-2014-5356 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 25 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-5356 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance (PyPI): affected all versions; fixed in 11.0.0a0
- glance (PyPI): affected all versions; fixed in 11.0.0a0
- glance (PyPI): affected all versions; fixed in 11.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5356/ (Markdown: https://insights.sbomify.com/CVE-2014-5356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5356
- OSV: https://osv.dev/vulnerability/CVE-2014-5356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5356/
Summaries are generated and may contain mistakes; the official description above is the record.
