# CVE-2014-5401: Hospira MedNet Code Injection


- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Mar 2019
- **Updated:** 3 Nov 2025
- **Also known as:** GHSA-8845-p3hj-8543

## What is CVE-2014-5401?

CVE-2014-5401 is a critical vulnerability in Hospira MedNet, published on 26 Mar 2019. 

### Official description

Hospira MedNet software version 5.8 and prior uses vulnerable versions of the JBoss Enterprise Application Platform software that may allow unauthenticated users to execute arbitrary code on the target system. Hospira has developed a new version of the MedNet software, MedNet 6.1. Existing versions of MedNet can be upgraded to MedNet 6.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-5401?

It affects 1 product.


Products: Hospira Mednet.

## How do I fix CVE-2014-5401?

No fix has been published for CVE-2014-5401 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-5401 being exploited?

There is no known exploitation of CVE-2014-5401 in the wild and no public exploit code.

## Other vulnerabilities in Hospira MedNet

- [CVE-2014-5405](https://insights.sbomify.com/CVE-2014-5405/): Hospira MedNet Use of Hard-coded Password (critical 9.0)
- [CVE-2014-5400](https://insights.sbomify.com/CVE-2014-5400/): Hospira MedNet Password in Configuration File (medium 6.8)
- [CVE-2014-5403](https://insights.sbomify.com/CVE-2014-5403/): Hospira MedNet Use of Hard-coded Cryptographic Key (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-5401 and fix it if it is affected.

What it is: CVE-2014-5401 is a critical vulnerability in Hospira MedNet, published on 26 Mar 2019. 
Exploitation: There is no known exploitation of CVE-2014-5401 in the wild and no public exploit code.

Affected product: Hospira MedNet. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-5401/ (Markdown: https://insights.sbomify.com/CVE-2014-5401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-5401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-5401
- OSV: https://osv.dev/vulnerability/CVE-2014-5401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-5401/
Summaries are generated and may contain mistakes; the official description above is the record.
