# CVE-2014-6038: Information disclosure in n/a

> Attackers can access sensitive database information in Zoho ManageEngine EventLog Analyzer, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-pm74-7m74-gxrf

## What is CVE-2014-6038?

CVE-2014-6038 is a high-severity vulnerability in n/a, published on 13 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zoho ManageEngine EventLog Analyzer versions 7 through 9.9 build 9002 have a database Information Disclosure Vulnerability. Fixed in EventLog Analyzer 10.0 Build 10000.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-6038?

It affects 1 product.


Products: Zohocorp Manageengine Eventlog Analyzer.

## How do I fix CVE-2014-6038?

No fix has been published for CVE-2014-6038 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-6038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-6038 exists.

Public exploit code:

- ManageEngine EventLog Analyzer - Multiple Vulnerabilities (2) (exploitdb)
- ManageEngine Eventlog Analyzer Managed Hosts Administrator Credential Disclosure (metasploit)

## Other vulnerabilities in n/a

- [CVE-2021-28959](https://insights.sbomify.com/CVE-2021-28959/): Path traversal in n/a (critical 9.8)
- [CVE-2019-19774](https://insights.sbomify.com/CVE-2019-19774/): Security feature bypass in n/a (high 8.8)
- [CVE-2014-6039](https://insights.sbomify.com/CVE-2014-6039/): Information disclosure in n/a (high 7.5)
- [CVE-2015-7387](https://insights.sbomify.com/CVE-2015-7387/): SQL injection in n/a (high 7.5)
- [CVE-2014-6037](https://insights.sbomify.com/CVE-2014-6037/): Path traversal in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6038 and fix it if it is affected.

What it is: CVE-2014-6038 is a high-severity vulnerability in n/a, published on 13 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-6038 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6038/ (Markdown: https://insights.sbomify.com/CVE-2014-6038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6038
- OSV: https://osv.dev/vulnerability/CVE-2014-6038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6038/
Summaries are generated and may contain mistakes; the official description above is the record.
