{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-6272 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-6272 is a high-severity vulnerability in Debian Debian Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-6272 and fix it if it is affected.\n\nWhat it is: CVE-2014-6272 is a high-severity vulnerability in Debian Debian Linux, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-6272 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-6272/ (Markdown: https://insights.sbomify.com/CVE-2014-6272/index.md)","id":"CVE-2014-6272","markdown":"https://insights.sbomify.com/CVE-2014-6272/index.md","name":"CVE-2014-6272","record":{"aliases":["DEBIAN-CVE-2014-6272","DLA-137-1","GHSA-246p-m32j-f38r","MGASA-2015-0009","UBUNTU-CVE-2014-6272","USN-2477-1","openSUSE-SU-2024:10236-1","openSUSE-SU-2024:10720-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Libevent library","requires_auth":"none","summary":"Integer overflows in Libevent allow attackers to cause denial of service or potential code execution via large inputs.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"libevent","vendor":"libevent_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-189","name":null}],"description":"Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via \"insanely large inputs\" to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop.  NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2015-6525 for the functions that are only affected in 2.0 and later.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2014-6272","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"integer_overflow","year":"2014"},"n_packages":1,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2014-6273"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.1.0-1.2"],"introduced":["0"],"last_affected":[],"package":"dnscrypt-proxy","purl":"pkg:rpm/opensuse/dnscrypt-proxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10720-1"}],"prev":{"headline":"GNU Bourne-Again Shell (Bash) Arbitrary Code Execution","id":"CVE-2014-6271"},"products":["n/a"],"published":"2015-08-24","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Integer overflows in Libevent allow attackers to cause denial of service or potential code execution via large inputs.","url":"https://insights.sbomify.com/CVE-2014-6272/"}