{"answers":{"affected":"1 open source package ship an affected version, including git-annex. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-6274 in the wild and no public exploit code.","fix":"Upgrade git-annex to 5.20140919 or later.","what":"CVE-2014-6274 is a high-severity vulnerability in git-annex, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-6274 and fix it if it is affected.\n\nWhat it is: CVE-2014-6274 is a high-severity vulnerability in git-annex, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-6274 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-annex (Hackage): affected from 0.20110401; fixed in 5.20140919\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-6274/ (Markdown: https://insights.sbomify.com/CVE-2014-6274/index.md)","id":"CVE-2014-6274","markdown":"https://insights.sbomify.com/CVE-2014-6274/index.md","name":"CVE-2014-6274","record":{"aliases":["DEBIAN-CVE-2014-6274","GHSA-ppj6-rmfj-4vjx","HSEC-2023-0013"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"git-annex","requires_auth":"none","summary":"Attackers with repository access can read plaintext AWS credentials when specific encryption and embedding options are enabled.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"git-annex","vendor":"git-annex_project"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"git-annex had a bug in the S3 and Glacier remotes where if embedcreds=yes\nwas set, and the remote used encryption=pubkey or encryption=hybrid,\nthe embedded AWS credentials were stored in the git repository\nin (effectively) plaintext, not encrypted as they were supposed to be. This issue affects git-annex: from 3.20121126 before 5.20140919.","ecosystems":["Hackage"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"S3 and Glacier remotes creds embedded in the git repo were not encrypted","id":"CVE-2014-6274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"hardcoded_credentials","year":"2014"},"n_packages":1,"n_references":1,"next":{"headline":"Information disclosure in FusionForge","id":"CVE-2014-6275"},"packages":[{"ecosystem":"Hackage","fixed":["5.20140919"],"introduced":["0.20110401"],"last_affected":[],"package":"git-annex","purl":"pkg:hackage/git-annex","source":"HSEC-2023-0013"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2014-6273"},"products":["git-annex"],"published":"2025-06-26","related":[{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2017-12976","kev_date_added":null,"published":"2017-08-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"open","licence":"CC0 1.0","name":"Haskell Security Response Team","prefix":"HSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-27","vendors":["git-annex"]},"summary":"Attackers with repository access can read plaintext AWS credentials when specific encryption and embedding options are enabled.","url":"https://insights.sbomify.com/CVE-2014-6274/"}