# CVE-2014-6274: S3 and Glacier remotes creds embedded in the git repo were not encrypted

> Attackers with repository access can read plaintext AWS credentials when specific encryption and embedding options are enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2025
- **Updated:** 27 Jun 2025
- **Also known as:** DEBIAN-CVE-2014-6274, GHSA-ppj6-rmfj-4vjx, HSEC-2023-0013

## What is CVE-2014-6274?

CVE-2014-6274 is a high-severity vulnerability in git-annex, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

git-annex had a bug in the S3 and Glacier remotes where if embedcreds=yes
was set, and the remote used encryption=pubkey or encryption=hybrid,
the embedded AWS credentials were stored in the git repository
in (effectively) plaintext, not encrypted as they were supposed to be. This issue affects git-annex: from 3.20121126 before 5.20140919.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2014-6274?

1 open source package ship an affected version, including git-annex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-annex` | Hackage | From 0.20110401 | 5.20140919 |

Products: Git-Annex Project Git-Annex.

## How do I fix CVE-2014-6274?

Upgrade git-annex to 5.20140919 or later.

## Is CVE-2014-6274 being exploited?

There is no known exploitation of CVE-2014-6274 in the wild and no public exploit code.

## Other vulnerabilities in git-annex

- [CVE-2017-12976](https://insights.sbomify.com/CVE-2017-12976/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6274 and fix it if it is affected.

What it is: CVE-2014-6274 is a high-severity vulnerability in git-annex, published on 26 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6274 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-annex (Hackage): affected from 0.20110401; fixed in 5.20140919

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6274/ (Markdown: https://insights.sbomify.com/CVE-2014-6274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6274
- OSV: https://osv.dev/vulnerability/CVE-2014-6274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6274/
Summaries are generated and may contain mistakes; the official description above is the record.
