{"answers":{"affected":"3 open source packages ship an affected version, including roundup. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-6276 in the wild and no public exploit code.","fix":"Upgrade roundup to 1.5.1 or later.","what":"CVE-2014-6276 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-6276 and fix it if it is affected.\n\nWhat it is: CVE-2014-6276 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-6276 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- roundup (PyPI): affected all versions; fixed in 1.5.1\n- roundup (PyPI): affected all versions; fixed in 1.5.1\n- roundup (PyPI): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-6276/ (Markdown: https://insights.sbomify.com/CVE-2014-6276/index.md)","id":"CVE-2014-6276","markdown":"https://insights.sbomify.com/CVE-2014-6276/index.md","name":"CVE-2014-6276","record":{"aliases":["DSA-3502-1","GHSA-j556-q367-2gw6","PYSEC-2016-33","UBUNTU-CVE-2014-6276"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Roundup issue tracker","requires_auth":"low_privilege","summary":"Authenticated users can view sensitive user details due to improper permission limits in Roundup issue tracker.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"roundup","vendor":"roundup-tracker"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Roundup sensitive data disclosure vulnerability","id":"CVE-2014-6276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"information_disclosure","year":"2014"},"n_packages":3,"n_references":3,"next":{"headline":"Code injection in n/a","id":"CVE-2014-6277"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":null,"source":"GHSA-j556-q367-2gw6"},{"ecosystem":"PyPI","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"GHSA-j556-q367-2gw6"},{"ecosystem":"PyPI","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"PYSEC-2016-33"}],"prev":{"headline":"Information disclosure in FusionForge","id":"CVE-2014-6275"},"products":["n/a"],"published":"2016-04-13","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can view sensitive user details due to improper permission limits in Roundup issue tracker.","url":"https://insights.sbomify.com/CVE-2014-6276/"}