# CVE-2014-6276: Roundup sensitive data disclosure vulnerability

> Authenticated users can view sensitive user details due to improper permission limits in Roundup issue tracker.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DSA-3502-1, GHSA-j556-q367-2gw6, PYSEC-2016-33, UBUNTU-CVE-2014-6276

## What is CVE-2014-6276?

CVE-2014-6276 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.

Weakness: CWE-264

## Which versions are affected by CVE-2014-6276?

3 open source packages ship an affected version, including roundup. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundup` | PyPI | All versions | 1.5.1 |
| `roundup` | PyPI | All versions | 1.5.1 |
| `roundup` | PyPI | All versions | 1.5.1 |

Products: Debian Debian Linux, Roundup-Tracker Roundup.

## How do I fix CVE-2014-6276?

Upgrade roundup to 1.5.1 or later.

## Is CVE-2014-6276 being exploited?

There is no known exploitation of CVE-2014-6276 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6276 and fix it if it is affected.

What it is: CVE-2014-6276 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6276 in the wild and no public exploit code.

Affected packages and fixed versions:
- roundup (PyPI): affected all versions; fixed in 1.5.1
- roundup (PyPI): affected all versions; fixed in 1.5.1
- roundup (PyPI): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6276/ (Markdown: https://insights.sbomify.com/CVE-2014-6276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6276
- OSV: https://osv.dev/vulnerability/CVE-2014-6276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6276/
Summaries are generated and may contain mistakes; the official description above is the record.
