# CVE-2014-6288: TYPO3 powermail extension allows remote attackers to bypass CAPTCHA protection mechanism

> Remote attackers can bypass CAPTCHA protection in the TYPO3 powermail extension, allowing automated spam or abuse.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2jq7-pgqq-gqqj

## What is CVE-2014-6288?

CVE-2014-6288 is a high-severity vulnerability in n/a, published on 3 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The powermail extension 2.x before 2.0.11 for TYPO3 allows remote attackers to bypass the CAPTCHA protection mechanism via unspecified vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2014-6288?

2 open source packages ship an affected version, including in2code/powermail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/powermail` | Packagist | From 2.0.0 | 2.0.11 |
| `in2code/powermail` | Packagist | From 2.0.0 | 2.0.11 |

Products: Alex Kellner Powermail.

## How do I fix CVE-2014-6288?

Upgrade in2code/powermail to 2.0.11 or later.

## Is CVE-2014-6288 being exploited?

There is no known exploitation of CVE-2014-6288 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3947](https://insights.sbomify.com/CVE-2014-3947/): TYPO3 powermail extension has unrestricted file upload vulnerability (high 7.5)
- [CVE-2010-3604](https://insights.sbomify.com/CVE-2010-3604/): powermail extension for TYPO3 vulnerable to SQL Injection (high 7.5)
- [CVE-2010-0329](https://insights.sbomify.com/CVE-2010-0329/): TYPO3 powermail Extension Vulnerable to SQL Injection via Unspecified Vectors (high 7.5)
- [CVE-2010-3687](https://insights.sbomify.com/CVE-2010-3687/): Business logic in n/a (medium 5.0)
- [CVE-2014-3948](https://insights.sbomify.com/CVE-2014-3948/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6288 and fix it if it is affected.

What it is: CVE-2014-6288 is a high-severity vulnerability in n/a, published on 3 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6288 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/powermail (Packagist): affected from 2.0.0; fixed in 2.0.11
- in2code/powermail (Packagist): affected from 2.0.0; fixed in 2.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6288/ (Markdown: https://insights.sbomify.com/CVE-2014-6288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6288
- OSV: https://osv.dev/vulnerability/CVE-2014-6288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6288/
Summaries are generated and may contain mistakes; the official description above is the record.
