# CVE-2014-6292: TYPO3 femanager extension allows remote frontend users to modify or delete records of other frontend users

> Remote authenticated users can modify or delete other users' records due to missing authorization checks in the femanager extension.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-377v-8637-6vq6

## What is CVE-2014-6292?

CVE-2014-6292 is a medium-severity missing authorization vulnerability in n/a, published on 3 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The femanager extension before 1.0.9 for TYPO3 allows remote frontend users to modify or delete the records of other frontend users via unspecified vectors.

## Which versions are affected by CVE-2014-6292?

2 open source packages ship an affected version, including in2code/femanager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/femanager` | Packagist | All versions | 1.0.9 |
| `in2code/femanager` | Packagist | All versions | 1.0.9 |

Products: In2code Femanager.

## How do I fix CVE-2014-6292?

Upgrade in2code/femanager to 1.0.9 or later.

## Is CVE-2014-6292 being exploited?

There is no known exploitation of CVE-2014-6292 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-25013](https://insights.sbomify.com/CVE-2023-25013/): Broken Access Control in 3rd party TYPO3 extension "femanager" (high 8.6)
- [CVE-2023-25014](https://insights.sbomify.com/CVE-2023-25014/): Broken Access Control in 3rd party TYPO3 extension "femanager" (high 8.6)
- [CVE-2021-36787](https://insights.sbomify.com/CVE-2021-36787/): Cross-site Scripting in the femanager TYPO3 extension (medium 5.4)
- [CVE-2022-44543](https://insights.sbomify.com/CVE-2022-44543/): TYPO3 Extension femanager vulnerable to Broken Access Control (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6292 and fix it if it is affected.

What it is: CVE-2014-6292 is a medium-severity missing authorization vulnerability in n/a, published on 3 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6292 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/femanager (Packagist): affected all versions; fixed in 1.0.9
- in2code/femanager (Packagist): affected all versions; fixed in 1.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6292/ (Markdown: https://insights.sbomify.com/CVE-2014-6292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6292
- OSV: https://osv.dev/vulnerability/CVE-2014-6292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6292/
Summaries are generated and may contain mistakes; the official description above is the record.
