# CVE-2014-6295: WEC Map (wec_map) extension for TYPO3 allows SQL Injection

> Remote attackers can execute arbitrary SQL commands in the WEC Map extension for TYPO3, potentially compromising database integrity and confidentiality.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f3v6-g4mv-pjhq

## What is CVE-2014-6295?

CVE-2014-6295 is a high-severity SQL injection vulnerability in n/a, published on 3 Oct 2014. It can be exploited over the network, with no action from the victim.

### Official description

SQL injection vulnerability in the WEC Map (wec_map) extension before 3.0.3 for TYPO3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-6295?

4 open source packages ship an affected version, including jbartels/wec-map and web-tp3/wec_map. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jbartels/wec-map` | Packagist | All versions | 3.0.3 |
| `jbartels/wec-map` | Packagist | All versions | 3.0.3 |
| `web-tp3/wec_map` | Packagist | All versions | 3.0.3 |
| `web-tp3/wec_map` | Packagist | All versions | 3.0.3 |

Products: Wec Map Project Wec Map.

## How do I fix CVE-2014-6295?

Upgrade jbartels/wec-map to 3.0.3 or later.

## Is CVE-2014-6295 being exploited?

There is no known exploitation of CVE-2014-6295 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-6296](https://insights.sbomify.com/CVE-2014-6296/): WEC Map (wec_map) extension for TYPO3 allows Cross-site Scripting (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6295 and fix it if it is affected.

What it is: CVE-2014-6295 is a high-severity SQL injection vulnerability in n/a, published on 3 Oct 2014. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6295 in the wild and no public exploit code.

Affected packages and fixed versions:
- jbartels/wec-map (Packagist): affected all versions; fixed in 3.0.3
- jbartels/wec-map (Packagist): affected all versions; fixed in 3.0.3
- web-tp3/wec_map (Packagist): affected all versions; fixed in 3.0.3
- web-tp3/wec_map (Packagist): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6295/ (Markdown: https://insights.sbomify.com/CVE-2014-6295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6295
- OSV: https://osv.dev/vulnerability/CVE-2014-6295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6295/
Summaries are generated and may contain mistakes; the official description above is the record.
