CVE-2014-6300 phpMyAdmin micro history Implementation XSS Vulnerability
Remote attackers can inject scripts via crafted URLs to perform CSRF attacks and create root accounts in phpMyAdmin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-6300?
CVE-2014-6300 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 8 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the micro history implementation in phpMyAdmin 4.0.x before 4.0.10.3, 4.1.x before 4.1.14.4, and 4.2.x before 4.2.8.1 allows remote attackers to inject arbitrary web script or HTML, and consequently conduct a cross-site request forgery (CSRF) attack to create a root account, via a crafted URL, related to js/ajax.js.
Weakness: CWE-79
Which versions are affected by CVE-2014-6300?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.3 |
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.3 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.4 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.4 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.8.1 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.8.1 |
Products include Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2014-6300?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.3, 4.1.14.4 or 4.2.8.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-6300 being exploited?
There is no known exploitation of CVE-2014-6300 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-6300, GHSA-6wfj-2mw7-p5cg, MGASA-2014-0383, UBUNTU-CVE-2014-6300.