{"answers":{"affected":"4 open source packages ship an affected version, including express. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-6393 in the wild and no public exploit code.","fix":"Upgrade express to a fixed version for your release line: 3.11.0 or 4.5.0.","what":"CVE-2014-6393 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-6393 and fix it if it is affected.\n\nWhat it is: CVE-2014-6393 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-6393 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express (npm): affected all versions; fixed in 3.11.0\n- express (npm): affected all versions; fixed in 3.11.0\n- express (npm): affected from 4.0.0; fixed in 4.5.0\n- express (npm): affected from 4.0.0; fixed in 4.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-6393/ (Markdown: https://insights.sbomify.com/CVE-2014-6393/index.md)","id":"CVE-2014-6393","markdown":"https://insights.sbomify.com/CVE-2014-6393/index.md","name":"CVE-2014-6393","record":{"aliases":["DEBIAN-CVE-2014-6393","GHSA-gpvr-g6gh-9mc2","UBUNTU-CVE-2014-6393"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"Remote attackers can execute cross-site scripting attacks via non-standard encoding in Express framework error responses due to missing charset headers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"express","vendor":"openjsf"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"No Charset in Content-Type Header in express","id":"CVE-2014-6393","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":4,"n_references":2,"next":{"headline":"Directory Traversal in send","id":"CVE-2014-6394"},"packages":[{"ecosystem":"npm","fixed":["3.11.0"],"introduced":["0"],"last_affected":[],"package":"express","purl":null,"source":"GHSA-gpvr-g6gh-9mc2"},{"ecosystem":"npm","fixed":["3.11.0"],"introduced":["0"],"last_affected":[],"package":"express","purl":"pkg:npm/express","source":"GHSA-gpvr-g6gh-9mc2"},{"ecosystem":"npm","fixed":["4.5.0"],"introduced":["4.0.0"],"last_affected":[],"package":"express","purl":null,"source":"GHSA-gpvr-g6gh-9mc2"},{"ecosystem":"npm","fixed":["4.5.0"],"introduced":["4.0.0"],"last_affected":[],"package":"express","purl":"pkg:npm/express","source":"GHSA-gpvr-g6gh-9mc2"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-6392"},"products":["n/a"],"published":"2017-08-09","related":[{"cvss_score":6.1,"headline":"Express.js Open Redirect in malformed URLs","id":"CVE-2024-29041","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":5,"headline":"express vulnerable to XSS via response.redirect()","id":"CVE-2024-43796","kev_date_added":null,"published":"2024-09-10"},{"cvss_score":4,"headline":"Preload arbitrary resources by injecting additional `Link` headers","id":"CVE-2024-10491","kev_date_added":null,"published":"2024-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute cross-site scripting attacks via non-standard encoding in Express framework error responses due to missing charset headers.","url":"https://insights.sbomify.com/CVE-2014-6393/"}