# CVE-2014-6407: Arbitrary Code Execution in Docker

> Remote attackers can execute arbitrary code and write files via symlink or hard link attacks in Docker image archives during pull or load operations.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** CVE-2014-3605, DEBIAN-CVE-2014-6407, GHSA-5qgp-p5jc-w2rm, GO-2022-0630

## What is CVE-2014-6407?

CVE-2014-6407 is a high-severity path traversal vulnerability in n/a, published on 12 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docker before 1.3.2 allows remote attackers to write to arbitrary files and execute arbitrary code via a (1) symlink or (2) hard link attack in an image archive in a (a) pull or (b) load operation.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2014-6407?

3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 1.3.2 |
| `github.com/docker/docker` | Go | All versions | 1.3.2 |
| `github.com/docker/docker` | Go | All versions | 1.3.2 |

Products: Docker Docker.

## How do I fix CVE-2014-6407?

Upgrade github.com/docker/docker to 1.3.2 or later.

## Is CVE-2014-6407 being exploited?

There is no known exploitation of CVE-2014-6407 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-9357](https://insights.sbomify.com/CVE-2014-9357/): Arbitrary Code Execution (critical 10.0)
- [CVE-2020-14298](https://insights.sbomify.com/CVE-2020-14298/): Privilege escalation in Docker (high 8.8)
- [CVE-2020-14300](https://insights.sbomify.com/CVE-2020-14300/): Privilege escalation in Docker (high 8.8)
- [CVE-2018-15514](https://insights.sbomify.com/CVE-2018-15514/): Deserialization in n/a (high 8.8)
- [CVE-2014-9356](https://insights.sbomify.com/CVE-2014-9356/): Path Traversal in Docker (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6407 and fix it if it is affected.

What it is: CVE-2014-6407 is a high-severity path traversal vulnerability in n/a, published on 12 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6407 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.2
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.2
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6407/ (Markdown: https://insights.sbomify.com/CVE-2014-6407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6407
- OSV: https://osv.dev/vulnerability/CVE-2014-6407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6407/
Summaries are generated and may contain mistakes; the official description above is the record.
