CVE-2014-6408 Access Restriction Bypass in Docker
Medium 5.0
Published
Updated
Check this codebase for CVE-2014-6408 and fix it if it is affected.
What it is: CVE-2014-6408 is a medium-severity vulnerability in n/a, published on 12 Dec 2014.
Exploitation: There is no known exploitation of CVE-2014-6408 in the wild and no public exploit code.
Affected packages and fixed versions:
- github.com/docker/docker (Go): affected from 1.3.0; fixed in 1.3.2
- github.com/docker/docker (Go): affected from 1.3.0; fixed in 1.3.2
- github.com/docker/docker (Go): affected from 1.3.0; fixed in 1.3.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2014-6408/ (Markdown: https://insights.sbomify.com/CVE-2014-6408/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2014-6408?
CVE-2014-6408 is a medium-severity vulnerability in n/a, published on 12 Dec 2014.
Official description
Docker 1.3.0 through 1.3.1 allows remote attackers to modify the default run profile of image containers and possibly bypass the container by applying unspecified security options to an image.
Weakness: CWE-264
Which versions are affected by CVE-2014-6408?
3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/docker/docker Go | From 1.3.0 | 1.3.2 |
github.com/docker/docker Go | From 1.3.0 | 1.3.2 |
github.com/docker/docker Go | From 1.3.0 | 1.3.2 |
Products include Docker Docker.
How do I fix CVE-2014-6408?
Upgrade github.com/docker/docker to 1.3.2 or later.
Is CVE-2014-6408 being exploited?
There is no known exploitation of CVE-2014-6408 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2014-6408, GHSA-44gg-pmqr-4669, GO-2022-0625.