# CVE-2014-6633: Tryton vulnerable to arbitrary command execution

> Remote authenticated users can execute arbitrary commands via shell metacharacters in specific Tryton fields, requiring an upgrade to secure the application.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-6633, DLA-70-1, DSA-3043-1, GHSA-m9jj-5qvj-5fhx, PYSEC-2018-59, PYSEC-2026-3390

## What is CVE-2014-6633?

CVE-2014-6633 is a high-severity command injection vulnerability in n/a, published on 12 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The safe_eval function in trytond in Tryton before 2.4.15, 2.6.x before 2.6.14, 2.8.x before 2.8.11, 3.0.x before 3.0.7, and 3.2.x before 3.2.3 allows remote authenticated users to execute arbitrary commands via shell metacharacters in (1) the collection.domain in the webdav module or (2) the formula field in the price_list module.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2014-6633?

20 open source packages ship an affected version, including trytond and tryton. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trytond` | PyPI | From 2.4.0 | 2.4.15, 2.6.14, 2.8.11, 3.0.7, 3.2.3 |
| `trytond` | PyPI | From 2.4.0 | 2.4.15 |
| `trytond` | PyPI | From 2.4.0 | 2.4.15 |
| `trytond` | PyPI | From 2.6.0 | 2.6.14 |
| `trytond` | PyPI | From 2.6.0 | 2.6.14 |
| `trytond` | PyPI | From 2.8.0 | 2.8.11 |
| `trytond` | PyPI | From 2.8.0 | 2.8.11 |
| `trytond` | PyPI | From 3.0.0 | 3.0.7 |
| `trytond` | PyPI | From 3.0.0 | 3.0.7 |
| `trytond` | PyPI | From 3.2.0 | 3.2.3 |
| `trytond` | PyPI | From 3.2.0 | 3.2.3 |
| `tryton` | PyPI | All versions | 2.4.15, 2.6.14, 2.8.11, 3.2.3 |
| `tryton` | PyPI | All versions | 2.4.15 |
| `tryton` | PyPI | All versions | 2.4.15 |
| `tryton` | PyPI | From 2.6.0 | 2.6.14 |
| `tryton` | PyPI | From 2.6.0 | 2.6.14 |
| `tryton` | PyPI | From 2.8.0 | 2.8.11 |
| `tryton` | PyPI | From 2.8.0 | 2.8.11 |
| `tryton` | PyPI | From 3.2.0 | 3.2.3 |
| `tryton` | PyPI | From 3.2.0 | 3.2.3 |

Products: Tryton Tryton.

## How do I fix CVE-2014-6633?

Upgrade trytond to a fixed version for your release line: 2.4.15, 2.6.14, 2.8.11 or 3.0.7.

## Is CVE-2014-6633 being exploited?

There is no known exploitation of CVE-2014-6633 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4510](https://insights.sbomify.com/CVE-2013-4510/): Tryton Directory Traversal vulnerability (high 7.8)
- [CVE-2018-19443](https://insights.sbomify.com/CVE-2018-19443/): Session Fixation in Tryton (medium 5.9)
- [CVE-2017-0360](https://insights.sbomify.com/CVE-2017-0360/): Tryton Information Disclosure Vulnerability (medium 5.3)
- [CVE-2016-1241](https://insights.sbomify.com/CVE-2016-1241/): Tryton allows users to read the hashed password (medium 5.3)
- [CVE-2016-1242](https://insights.sbomify.com/CVE-2016-1242/): Tryton allow authenticated users with certain permissions to read arbitrary files via the name parameter (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-6633 and fix it if it is affected.

What it is: CVE-2014-6633 is a high-severity command injection vulnerability in n/a, published on 12 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-6633 in the wild and no public exploit code.

Affected packages and fixed versions:
- trytond (PyPI): affected from 2.4.0; fixed in 2.4.15, 2.6.14, 2.8.11, 3.0.7, 3.2.3
- trytond (PyPI): affected from 2.4.0; fixed in 2.4.15
- trytond (PyPI): affected from 2.4.0; fixed in 2.4.15
- trytond (PyPI): affected from 2.6.0; fixed in 2.6.14
- trytond (PyPI): affected from 2.6.0; fixed in 2.6.14
- trytond (PyPI): affected from 2.8.0; fixed in 2.8.11
- trytond (PyPI): affected from 2.8.0; fixed in 2.8.11
- trytond (PyPI): affected from 3.0.0; fixed in 3.0.7
- trytond (PyPI): affected from 3.0.0; fixed in 3.0.7
- trytond (PyPI): affected from 3.2.0; fixed in 3.2.3
- trytond (PyPI): affected from 3.2.0; fixed in 3.2.3
- tryton (PyPI): affected all versions; fixed in 2.4.15, 2.6.14, 2.8.11, 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-6633/ (Markdown: https://insights.sbomify.com/CVE-2014-6633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-6633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-6633
- OSV: https://osv.dev/vulnerability/CVE-2014-6633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-6633/
Summaries are generated and may contain mistakes; the official description above is the record.
