# CVE-2014-7143: Python Twisted trustRoot is not respected in HTTP client

> Attackers can bypass TLS certificate validation in the Twisted HTTP client, enabling man-in-the-middle attacks against applications using this library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-7143, GHSA-3c45-wgjp-7v9r, PYSEC-2019-212

## What is CVE-2014-7143?

CVE-2014-7143 is a high-severity vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python Twisted 14.0 trustRoot is not respected in HTTP client

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2014-7143?

3 open source packages ship an affected version, including twisted and Twisted. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 14.0.1 |
| `twisted` | PyPI | From 14.0.0 | 14.0.1 |
| `Twisted` | PyPI | From 14.0.0 | 14.0.1 |

Products: Twisted Twisted.

## How do I fix CVE-2014-7143?

Upgrade twisted to 14.0.1 or later.

## Is CVE-2014-7143 being exploited?

There is no known exploitation of CVE-2014-7143 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-42304](https://insights.sbomify.com/CVE-2026-42304/): Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains (high 7.5)
- [CVE-2019-12855](https://insights.sbomify.com/CVE-2019-12855/): Improper Certificate Validation in Twisted (high 7.4)
- [CVE-2024-41810](https://insights.sbomify.com/CVE-2024-41810/): HTML injection in HTTP redirect body (medium 6.1)
- [CVE-2023-46137](https://insights.sbomify.com/CVE-2023-46137/): twisted.web has disordered HTTP pipeline response (medium 5.3)
- [CVE-2016-1000111](https://insights.sbomify.com/CVE-2016-1000111/): Forced Browsing in Twisted (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7143 and fix it if it is affected.

What it is: CVE-2014-7143 is a high-severity vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7143 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 14.0.1
- twisted (PyPI): affected from 14.0.0; fixed in 14.0.1
- Twisted (PyPI): affected from 14.0.0; fixed in 14.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7143/ (Markdown: https://insights.sbomify.com/CVE-2014-7143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7143
- OSV: https://osv.dev/vulnerability/CVE-2014-7143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7143/
Summaries are generated and may contain mistakes; the official description above is the record.
