CVE-2014-7144 OpenStack keystonemiddleware does not verify certificate

Medium 4.3 Published Updated

OpenStack keystonemiddleware disables certificate verification when insecure option is set, allowing man-in-the-middle attacks via crafted certificates.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-7144?

CVE-2014-7144 is a medium-severity vulnerability in n/a, published on 2 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.

Weakness: CWE-310

Which versions are affected by CVE-2014-7144?

10 open source packages ship an affected version, including keystonemiddleware and python-keystoneclient. It affects 2 products.

PackageAffectedFixed in
keystonemiddleware PyPIAll versions0.11.0, 1.2.0
keystonemiddleware PyPIAll versions0.11.0
keystonemiddleware PyPIAll versions0.11.0
keystonemiddleware PyPIFrom 1.01.2.0
keystonemiddleware PyPIFrom 1.01.2.0
python-keystoneclient PyPIAll versions0.11.0, 1.2.0
4 more packages
python-keystoneclient PyPIAll versions0.11.0
python-keystoneclient PyPIAll versions0.11.0
python-keystoneclient PyPIFrom 1.01.2.0
python-keystoneclient PyPIFrom 1.01.2.0
Linux distribution packages (6)
python-keystoneclient Red Hat:openstack:4::el6All versions1:0.7.1-5.el6ost
python-keystoneclient-doc Red Hat:openstack:4::el6All versions1:0.7.1-5.el6ost
python-keystoneclient Red Hat:openstack:5::el6All versions1:0.9.0-5.el6ost
python-keystoneclient-doc Red Hat:openstack:5::el6All versions1:0.9.0-5.el6ost
python-keystoneclient Red Hat:openstack:5::el7All versions1:0.9.0-5.el7ost
python-keystoneclient-doc Red Hat:openstack:5::el7All versions1:0.9.0-5.el7ost

Products include Openstack Keystonemiddleware, Openstack Python-Keystoneclient.

How do I fix CVE-2014-7144?

Upgrade keystonemiddleware to a fixed version for your release line: 0.11.0 or 1.2.0.

Is CVE-2014-7144 being exploited?

There is no known exploitation of CVE-2014-7144 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2014-7144, GHSA-7f2c-vp52-gmfw, PYSEC-2014-26, PYSEC-2014-71, RHSA-2014:1783, RHSA-2014:1784 and 2 more.

Is CVE-2014-7144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free