# CVE-2014-7144: OpenStack keystonemiddleware does not verify certificate

> OpenStack keystonemiddleware disables certificate verification when insecure option is set, allowing man-in-the-middle attacks via crafted certificates.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-7144, GHSA-7f2c-vp52-gmfw, PYSEC-2014-26, PYSEC-2014-71, RHSA-2014:1783, RHSA-2014:1784, RHSA-2015:0020, UBUNTU-CVE-2014-7144

## What is CVE-2014-7144?

CVE-2014-7144 is a medium-severity vulnerability in n/a, published on 2 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.

Weakness: CWE-310

## Which versions are affected by CVE-2014-7144?

10 open source packages ship an affected version, including keystonemiddleware and python-keystoneclient. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystonemiddleware` | PyPI | All versions | 0.11.0, 1.2.0 |
| `keystonemiddleware` | PyPI | All versions | 0.11.0 |
| `keystonemiddleware` | PyPI | All versions | 0.11.0 |
| `keystonemiddleware` | PyPI | From 1.0 | 1.2.0 |
| `keystonemiddleware` | PyPI | From 1.0 | 1.2.0 |
| `python-keystoneclient` | PyPI | All versions | 0.11.0, 1.2.0 |
| `python-keystoneclient` | PyPI | All versions | 0.11.0 |
| `python-keystoneclient` | PyPI | All versions | 0.11.0 |
| `python-keystoneclient` | PyPI | From 1.0 | 1.2.0 |
| `python-keystoneclient` | PyPI | From 1.0 | 1.2.0 |
| `python-keystoneclient` | Red Hat:openstack:4::el6 | All versions | 1:0.7.1-5.el6ost |
| `python-keystoneclient-doc` | Red Hat:openstack:4::el6 | All versions | 1:0.7.1-5.el6ost |
| `python-keystoneclient` | Red Hat:openstack:5::el6 | All versions | 1:0.9.0-5.el6ost |
| `python-keystoneclient-doc` | Red Hat:openstack:5::el6 | All versions | 1:0.9.0-5.el6ost |
| `python-keystoneclient` | Red Hat:openstack:5::el7 | All versions | 1:0.9.0-5.el7ost |
| `python-keystoneclient-doc` | Red Hat:openstack:5::el7 | All versions | 1:0.9.0-5.el7ost |

Products: Openstack Keystonemiddleware, Openstack Python-Keystoneclient.

## How do I fix CVE-2014-7144?

Upgrade keystonemiddleware to a fixed version for your release line: 0.11.0 or 1.2.0.

## Is CVE-2014-7144 being exploited?

There is no known exploitation of CVE-2014-7144 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7144 and fix it if it is affected.

What it is: CVE-2014-7144 is a medium-severity vulnerability in n/a, published on 2 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7144 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystonemiddleware (PyPI): affected all versions; fixed in 0.11.0, 1.2.0
- keystonemiddleware (PyPI): affected all versions; fixed in 0.11.0
- keystonemiddleware (PyPI): affected all versions; fixed in 0.11.0
- keystonemiddleware (PyPI): affected from 1.0; fixed in 1.2.0
- keystonemiddleware (PyPI): affected from 1.0; fixed in 1.2.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.11.0, 1.2.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.11.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.11.0
- python-keystoneclient (PyPI): affected from 1.0; fixed in 1.2.0
- python-keystoneclient (PyPI): affected from 1.0; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7144/ (Markdown: https://insights.sbomify.com/CVE-2014-7144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7144
- OSV: https://osv.dev/vulnerability/CVE-2014-7144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7144/
Summaries are generated and may contain mistakes; the official description above is the record.
