{"answers":{"affected":"2 open source packages ship an affected version, including qs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-7191 in the wild and no public exploit code.","fix":"Upgrade qs to 1.0.0 or later.","what":"CVE-2014-7191 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 19 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-7191 and fix it if it is affected.\n\nWhat it is: CVE-2014-7191 is a medium-severity denial of service vulnerability in Nodejs Node.js, published on 19 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-7191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- qs (npm): affected all versions; fixed in 1.0.0\n- qs (npm): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-7191/ (Markdown: https://insights.sbomify.com/CVE-2014-7191/index.md)","id":"CVE-2014-7191","markdown":"https://insights.sbomify.com/CVE-2014-7191/index.md","name":"CVE-2014-7191","record":{"aliases":["DEBIAN-CVE-2014-7191","GHSA-jjv7-qpx3-h62q","RHSA-2016:1380","UBUNTU-CVE-2014-7191"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js qs module","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory consumption in the Node.js qs module by exploiting sparse array creation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial of service (memory consumption) by using a large index value to create a sparse array.","ecosystems":["Red Hat:rhel_software_collections:2::el6","Red Hat:rhel_software_collections:2::el7","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial-of-Service Memory Exhaustion in qs","id":"CVE-2014-7191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"denial_of_service","year":"2014"},"n_packages":6,"n_references":10,"next":{"headline":"Potential for Script Injection in syntax-error","id":"CVE-2014-7192"},"packages":[{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"qs","purl":null,"source":"GHSA-jjv7-qpx3-h62q"},{"ecosystem":"npm","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"qs","purl":"pkg:npm/qs","source":"GHSA-jjv7-qpx3-h62q"},{"ecosystem":"Red Hat:rhel_software_collections:2::el6","fixed":["0:3.2.0-3.el6"],"introduced":["0"],"last_affected":[],"package":"nodejs010-node-gyp","purl":"pkg:rpm/redhat/nodejs010-node-gyp","source":"RHSA-2016:1380"},{"ecosystem":"Red Hat:rhel_software_collections:2::el6","fixed":["0:0.6.5-5.el6"],"introduced":["0"],"last_affected":[],"package":"nodejs010-nodejs-qs","purl":"pkg:rpm/redhat/nodejs010-nodejs-qs","source":"RHSA-2016:1380"},{"ecosystem":"Red Hat:rhel_software_collections:2::el7","fixed":["0:3.2.0-3.el7"],"introduced":["0"],"last_affected":[],"package":"nodejs010-node-gyp","purl":"pkg:rpm/redhat/nodejs010-node-gyp","source":"RHSA-2016:1380"},{"ecosystem":"Red Hat:rhel_software_collections:2::el7","fixed":["0:0.6.5-5.el7"],"introduced":["0"],"last_affected":[],"package":"nodejs010-nodejs-qs","purl":"pkg:rpm/redhat/nodejs010-nodejs-qs","source":"RHSA-2016:1380"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2014-7190"},"products":["n/a"],"published":"2014-10-19","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory consumption in the Node.js qs module by exploiting sparse array creation.","url":"https://insights.sbomify.com/CVE-2014-7191/"}