{"answers":{"affected":"2 open source packages ship an affected version, including syntax-error. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-7192 in the wild and no public exploit code.","fix":"Upgrade syntax-error to 1.1.1 or later.","what":"CVE-2014-7192 is a critical code injection vulnerability in n/a, published on 11 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-7192 and fix it if it is affected.\n\nWhat it is: CVE-2014-7192 is a critical code injection vulnerability in n/a, published on 11 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-7192 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- syntax-error (npm): affected all versions; fixed in 1.1.1\n- syntax-error (npm): affected all versions; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-7192/ (Markdown: https://insights.sbomify.com/CVE-2014-7192/index.md)","id":"CVE-2014-7192","markdown":"https://insights.sbomify.com/CVE-2014-7192/index.md","name":"CVE-2014-7192","record":{"aliases":["GHSA-5726-g6r9-5f22","UBUNTU-CVE-2014-7192"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js syntax-error library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via a crafted file due to eval injection in the syntax-error Node.js library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node.js","vendor":"joyent"}],"cvss":{"score":10,"severity":"critical","source":"nvd","vector":"AV:N/AC:L/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2014-07-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2014-07-16","kind":"exploitdb","ref":"34090","stars":null,"title":"Node Browserify 4.2.0 - Remote Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Potential for Script Injection in syntax-error","id":"CVE-2014-7192","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"CORS Token Disclosure in crumb","id":"CVE-2014-7193"},"packages":[{"ecosystem":"npm","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"syntax-error","purl":null,"source":"GHSA-5726-g6r9-5f22"},{"ecosystem":"npm","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"syntax-error","purl":"pkg:npm/syntax-error","source":"GHSA-5726-g6r9-5f22"}],"prev":{"headline":"Denial-of-Service Memory Exhaustion in qs","id":"CVE-2014-7191"},"products":["n/a"],"published":"2014-12-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via a crafted file due to eval injection in the syntax-error Node.js library.","url":"https://insights.sbomify.com/CVE-2014-7192/"}