# CVE-2014-7192: Potential for Script Injection in syntax-error

> Remote attackers can execute arbitrary code via a crafted file due to eval injection in the syntax-error Node.js library.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5726-g6r9-5f22, UBUNTU-CVE-2014-7192

## What is CVE-2014-7192?

CVE-2014-7192 is a critical code injection vulnerability in n/a, published on 11 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-7192?

2 open source packages ship an affected version, including syntax-error. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `syntax-error` | npm | All versions | 1.1.1 |
| `syntax-error` | npm | All versions | 1.1.1 |

Products: Joyent Node.js.

## How do I fix CVE-2014-7192?

Upgrade syntax-error to 1.1.1 or later.

## Is CVE-2014-7192 being exploited?

There is no known exploitation of CVE-2014-7192 in the wild and no public exploit code.

Public exploit code:

- Node Browserify 4.2.0 - Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7192 and fix it if it is affected.

What it is: CVE-2014-7192 is a critical code injection vulnerability in n/a, published on 11 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-7192 in the wild and no public exploit code.

Affected packages and fixed versions:
- syntax-error (npm): affected all versions; fixed in 1.1.1
- syntax-error (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7192/ (Markdown: https://insights.sbomify.com/CVE-2014-7192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7192
- OSV: https://osv.dev/vulnerability/CVE-2014-7192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7192/
Summaries are generated and may contain mistakes; the official description above is the record.
