{"answers":{"affected":"2 open source packages ship an affected version, including crumb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-7193 in the wild and no public exploit code.","fix":"Upgrade crumb to 3.0.0 or later.","what":"CVE-2014-7193 is a medium-severity vulnerability in n/a, published on 25 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-7193 and fix it if it is affected.\n\nWhat it is: CVE-2014-7193 is a medium-severity vulnerability in n/a, published on 25 Dec 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-7193 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- crumb (npm): affected all versions; fixed in 3.0.0\n- crumb (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-7193/ (Markdown: https://insights.sbomify.com/CVE-2014-7193/index.md)","id":"CVE-2014-7193","markdown":"https://insights.sbomify.com/CVE-2014-7193/index.md","name":"CVE-2014-7193","record":{"aliases":["GHSA-84fq-6626-w5fg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js Crumb plugin","requires_auth":"none","summary":"Remote attackers can obtain sensitive information and spoof requests via a crafted website when CORS is enabled in hapi routes using the Crumb plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hapi_crumb","vendor":"sideway"}],"cvss":{"score":5.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"The Crumb plugin before 3.0.0 for Node.js does not properly restrict token access in situations where a hapi route handler has CORS enabled, which allows remote attackers to obtain sensitive information, and potentially obtain the ability to spoof requests to non-CORS routes, via a crafted web site that is visited by an application consumer.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CORS Token Disclosure in crumb","id":"CVE-2014-7193","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2014-7194"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"crumb","purl":null,"source":"GHSA-84fq-6626-w5fg"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"crumb","purl":"pkg:npm/crumb","source":"GHSA-84fq-6626-w5fg"}],"prev":{"headline":"Potential for Script Injection in syntax-error","id":"CVE-2014-7192"},"products":["n/a"],"published":"2014-12-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information and spoof requests via a crafted website when CORS is enabled in hapi routes using the Crumb plugin.","url":"https://insights.sbomify.com/CVE-2014-7193/"}