{"answers":{"affected":"2 open source packages ship an affected version, including bassmaster. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7205 exists.","fix":"Upgrade bassmaster to 1.5.2 or later.","what":"CVE-2014-7205 is a critical code injection vulnerability in n/a, published on 8 Oct 2014. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-7205 and fix it if it is affected.\n\nWhat it is: CVE-2014-7205 is a critical code injection vulnerability in n/a, published on 8 Oct 2014. It can be exploited over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7205 exists.\n\nAffected packages and fixed versions:\n- bassmaster (npm): affected all versions; fixed in 1.5.2\n- bassmaster (npm): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-7205/ (Markdown: https://insights.sbomify.com/CVE-2014-7205/index.md)","id":"CVE-2014-7205","markdown":"https://insights.sbomify.com/CVE-2014-7205/index.md","name":"CVE-2014-7205","record":{"aliases":["GHSA-5j3g-jfq3-7jwx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js hapi plugin","requires_auth":"unknown","summary":"Remote attackers can execute arbitrary JavaScript code via eval injection in the bassmaster plugin for the hapi framework.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bassmaster","vendor":"bassmaster_project"}],"cvss":{"score":10,"severity":"critical","source":"nvd","vector":"AV:N/AC:L/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Eval injection vulnerability in the internals.batch function in lib/batch.js in the bassmaster plugin before 1.5.2 for the hapi server framework for Node.js allows remote attackers to execute arbitrary Javascript code via unspecified vectors.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2016-11-01","github_poc":2,"max_poc_stars":3,"metasploit":1,"nuclei":0,"refs":[{"date":"2021-04-05T17:02:36Z","kind":"github_poc","ref":"https://github.com/maximilianmarx/bassmaster-rce","stars":3,"title":"Exploiting CVE-2014-7205 by injecting arbitrary JavaScript resulting in Remote Code Execution."},{"date":"2016-11-01","kind":"metasploit","ref":"exploit/multi/http/bassmaster_js_injection","stars":null,"title":"Bassmaster Batch Arbitrary JavaScript Injection Remote Code Execution"},{"date":"2016-11-02","kind":"exploitdb","ref":"40689","stars":null,"title":"Bassmaster 1.5.1 - Batch Arbitrary JavaScript Injection Remote Code Execution (Metasploit)"},{"date":"2022-01-04T02:59:32Z","kind":"github_poc","ref":"https://github.com/AndrewTrube/CVE-2014-7205","stars":0,"title":"Bassmaster Plugin NodeJS RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary JavaScript Execution in bassmaster","id":"CVE-2014-7205","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"Path traversal in n/a","id":"CVE-2014-7206"},"packages":[{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"bassmaster","purl":null,"source":"GHSA-5j3g-jfq3-7jwx"},{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"bassmaster","purl":"pkg:npm/bassmaster","source":"GHSA-5j3g-jfq3-7jwx"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2014-7204"},"products":["n/a"],"published":"2014-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary JavaScript code via eval injection in the bassmaster plugin for the hapi framework.","url":"https://insights.sbomify.com/CVE-2014-7205/"}