# CVE-2014-7205: Arbitrary JavaScript Execution in bassmaster

> Remote attackers can execute arbitrary JavaScript code via eval injection in the bassmaster plugin for the hapi framework.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5j3g-jfq3-7jwx

## What is CVE-2014-7205?

CVE-2014-7205 is a critical code injection vulnerability in n/a, published on 8 Oct 2014. It can be exploited over the network, with no action from the victim.

### Official description

Eval injection vulnerability in the internals.batch function in lib/batch.js in the bassmaster plugin before 1.5.2 for the hapi server framework for Node.js allows remote attackers to execute arbitrary Javascript code via unspecified vectors.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-7205?

2 open source packages ship an affected version, including bassmaster. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bassmaster` | npm | All versions | 1.5.2 |
| `bassmaster` | npm | All versions | 1.5.2 |

Products: Bassmaster Project Bassmaster.

## How do I fix CVE-2014-7205?

Upgrade bassmaster to 1.5.2 or later.

## Is CVE-2014-7205 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7205 exists.

Public exploit code:

- Exploiting CVE-2014-7205 by injecting arbitrary JavaScript resulting in Remote Code Execution. (github_poc): https://github.com/maximilianmarx/bassmaster-rce
- Bassmaster Batch Arbitrary JavaScript Injection Remote Code Execution (metasploit)
- Bassmaster 1.5.1 - Batch Arbitrary JavaScript Injection Remote Code Execution (Metasploit) (exploitdb)
- Bassmaster Plugin NodeJS RCE (github_poc): https://github.com/AndrewTrube/CVE-2014-7205

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7205 and fix it if it is affected.

What it is: CVE-2014-7205 is a critical code injection vulnerability in n/a, published on 8 Oct 2014. It can be exploited over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7205 exists.

Affected packages and fixed versions:
- bassmaster (npm): affected all versions; fixed in 1.5.2
- bassmaster (npm): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7205/ (Markdown: https://insights.sbomify.com/CVE-2014-7205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7205
- OSV: https://osv.dev/vulnerability/CVE-2014-7205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7205/
Summaries are generated and may contain mistakes; the official description above is the record.
