CVE-2014-7217 phpMyAdmin cross-site scripting Vulnerability via ENUM value
Authenticated users can inject arbitrary scripts via crafted ENUM values in phpMyAdmin, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-7217?
CVE-2014-7217 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 3 Oct 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted ENUM value that is improperly handled during rendering of the (1) table search or (2) table structure page, related to libraries/TableSearch.class.php and libraries/Util.class.php.
Weakness: CWE-79
Which versions are affected by CVE-2014-7217?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.4 |
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.4 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.5 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.5 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.9.1 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.9.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2014-7217?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.4, 4.1.14.5 or 4.2.9.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-7217 being exploited?
There is no known exploitation of CVE-2014-7217 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2014-7217, GHSA-wv8g-fx9j-q2jg, MGASA-2014-0402, UBUNTU-CVE-2014-7217.