CVE-2014-7808 Apache Wicket insecure defaults

High 7.5 Published Updated

Attackers can predict encrypted URLs by exploiting weak default cryptographic settings in the Apache Wicket web framework.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-7808?

CVE-2014-7808 is a high-severity vulnerability in n/a, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Weakness: CWE-310

Which versions are affected by CVE-2014-7808?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.

PackageAffectedFixed in
org.apache.wicket:wicket-core MavenAll versions1.5.13
org.apache.wicket:wicket-core MavenAll versions1.5.13
org.apache.wicket:wicket-core MavenFrom 6.0.0-beta16.19.0
org.apache.wicket:wicket-core MavenFrom 6.0.0-beta16.19.0
org.apache.wicket:wicket-core MavenFrom 7.0.0-M17.0.0-M5
org.apache.wicket:wicket-core MavenFrom 7.0.0-M17.0.0-M5

Products include Apache Wicket.

How do I fix CVE-2014-7808?

Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 1.5.13, 6.19.0 or 7.0.0-M5.

Is CVE-2014-7808 being exploited?

There is no known exploitation of CVE-2014-7808 in the wild and no public exploit code.

Sources

Also known as GHSA-vfmm-jm4v-7frq.

Is CVE-2014-7808 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free