# CVE-2014-7808: Apache Wicket insecure defaults

> Attackers can predict encrypted URLs by exploiting weak default cryptographic settings in the Apache Wicket web framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vfmm-jm4v-7frq

## What is CVE-2014-7808?

CVE-2014-7808 is a high-severity vulnerability in n/a, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.

Weakness: CWE-310

## Which versions are affected by CVE-2014-7808?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket-core` | Maven | All versions | 1.5.13 |
| `org.apache.wicket:wicket-core` | Maven | All versions | 1.5.13 |
| `org.apache.wicket:wicket-core` | Maven | From 6.0.0-beta1 | 6.19.0 |
| `org.apache.wicket:wicket-core` | Maven | From 6.0.0-beta1 | 6.19.0 |
| `org.apache.wicket:wicket-core` | Maven | From 7.0.0-M1 | 7.0.0-M5 |
| `org.apache.wicket:wicket-core` | Maven | From 7.0.0-M1 | 7.0.0-M5 |

Products: Apache Wicket.

## How do I fix CVE-2014-7808?

Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 1.5.13, 6.19.0 or 7.0.0-M5.

## Is CVE-2014-7808 being exploited?

There is no known exploitation of CVE-2014-7808 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7808 and fix it if it is affected.

What it is: CVE-2014-7808 is a high-severity vulnerability in n/a, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7808 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 1.5.13
- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 1.5.13
- org.apache.wicket:wicket-core (Maven): affected from 6.0.0-beta1; fixed in 6.19.0
- org.apache.wicket:wicket-core (Maven): affected from 6.0.0-beta1; fixed in 6.19.0
- org.apache.wicket:wicket-core (Maven): affected from 7.0.0-M1; fixed in 7.0.0-M5
- org.apache.wicket:wicket-core (Maven): affected from 7.0.0-M1; fixed in 7.0.0-M5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7808/ (Markdown: https://insights.sbomify.com/CVE-2014-7808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7808
- OSV: https://osv.dev/vulnerability/CVE-2014-7808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7808/
Summaries are generated and may contain mistakes; the official description above is the record.
