# CVE-2014-7816: Improper Limitation of a Pathname to a Restricted Directory in JBoss Undertow

> Remote attackers can read arbitrary files on Windows systems running JBoss Undertow via directory traversal in resource URIs.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h6p6-fc4w-cqhx

## What is CVE-2014-7816?

CVE-2014-7816 is a medium-severity path traversal vulnerability in n/a, published on 1 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in JBoss Undertow 1.0.x before 1.0.17, 1.1.x before 1.1.0.CR5, and 1.2.x before 1.2.0.Beta3, when running on Windows, allows remote attackers to read arbitrary files via a .. (dot dot) in a resource URI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-7816?

6 open source packages ship an affected version, including io.undertow:undertow-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.undertow:undertow-core` | Maven | From 1.0.0 | 1.0.17 |
| `io.undertow:undertow-core` | Maven | From 1.0.0 | 1.0.17 |
| `io.undertow:undertow-core` | Maven | From 1.1.0.Beta1 | 1.1.0.CR5 |
| `io.undertow:undertow-core` | Maven | From 1.1.0.Beta1 | 1.1.0.CR5 |
| `io.undertow:undertow-core` | Maven | From 1.2.0.Beta1 | 1.2.0.Beta3 |
| `io.undertow:undertow-core` | Maven | From 1.2.0.Beta1 | 1.2.0.Beta3 |

Products: Redhat Undertow.

## How do I fix CVE-2014-7816?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.0.17, 1.1.0.CR5 or 1.2.0.Beta3.

## Is CVE-2014-7816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7816 exists.

Public exploit code:

- WildFly Directory Traversal (metasploit)
- https://github.com/shoucheng3/undertow-io__undertow_CVE-2014-7816_1-0-16-Final (github_poc): https://github.com/shoucheng3/undertow-io__undertow_CVE-2014-7816_1-0-16-Final

## Other vulnerabilities in n/a

- [CVE-2020-1745](https://insights.sbomify.com/CVE-2020-1745/): Improper Authorization in Undertoe (high 8.6)
- [CVE-2018-1114](https://insights.sbomify.com/CVE-2018-1114/): Uncontrolled Resource Consumption in Undertow (medium 6.5)
- [CVE-2017-7559](https://insights.sbomify.com/CVE-2017-7559/): Undertow vulnerable to Request Smuggling (medium 6.1)
- [CVE-2024-1459](https://insights.sbomify.com/CVE-2024-1459/): Undertow: directory traversal vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7816 and fix it if it is affected.

What it is: CVE-2014-7816 is a medium-severity path traversal vulnerability in n/a, published on 1 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-7816 exists.

Affected packages and fixed versions:
- io.undertow:undertow-core (Maven): affected from 1.0.0; fixed in 1.0.17
- io.undertow:undertow-core (Maven): affected from 1.0.0; fixed in 1.0.17
- io.undertow:undertow-core (Maven): affected from 1.1.0.Beta1; fixed in 1.1.0.CR5
- io.undertow:undertow-core (Maven): affected from 1.1.0.Beta1; fixed in 1.1.0.CR5
- io.undertow:undertow-core (Maven): affected from 1.2.0.Beta1; fixed in 1.2.0.Beta3
- io.undertow:undertow-core (Maven): affected from 1.2.0.Beta1; fixed in 1.2.0.Beta3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7816/ (Markdown: https://insights.sbomify.com/CVE-2014-7816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7816
- OSV: https://osv.dev/vulnerability/CVE-2014-7816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7816/
Summaries are generated and may contain mistakes; the official description above is the record.
