CVE-2014-7818 actionpack vulnerable to Path Traversal
Remote attackers can determine the existence of files outside the application root via directory traversal when static asset serving is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-7818?
CVE-2014-7818 is a medium-severity path traversal vulnerability in Opensuse Opensuse, published on 8 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.20, 4.0.x before 4.0.11, 4.1.x before 4.1.7, and 4.2.x before 4.2.0.beta3, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via a /..%2F sequence.
Weakness: CWE-22
Which versions are affected by CVE-2014-7818?
8 open source packages ship an affected version, including actionpack. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 3.0.0 | 3.2.20 |
actionpack RubyGems | From 3.0.0 | 3.2.20 |
actionpack RubyGems | From 4.0.0 | 4.0.11 |
actionpack RubyGems | From 4.0.0 | 4.0.11 |
actionpack RubyGems | From 4.1.0 | 4.1.7 |
actionpack RubyGems | From 4.1.0 | 4.1.7 |
2 more packages
actionpack RubyGems | From 4.2.0.beta1 | 4.2.0.beta3 |
actionpack RubyGems | From 4.2.0.beta1 | 4.2.0.beta3 |
Products include Opensuse Opensuse, Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2014-7818?
Upgrade actionpack to a fixed version for your release line: 3.2.20, 4.0.11, 4.1.7 or 4.2.0.beta3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2014-7818 being exploited?
There is no known exploitation of CVE-2014-7818 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-7818, GHSA-29gr-w57f-rpfw.