# CVE-2014-7819: sprockets vulnerable to Path Traversal

> Remote attackers can determine the existence of files outside the application root using directory traversal sequences in Sprockets.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-7819, GHSA-33pp-3763-mrfp, MGASA-2015-0074, SUSE-SU-2015:0787-1

## What is CVE-2014-7819?

CVE-2014-7819 is a medium-severity path traversal vulnerability in n/a, published on 8 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple directory traversal vulnerabilities in server.rb in Sprockets before 2.0.5, 2.1.x before 2.1.4, 2.2.x before 2.2.3, 2.3.x before 2.3.3, 2.4.x before 2.4.6, 2.5.x before 2.5.1, 2.6.x and 2.7.x before 2.7.1, 2.8.x before 2.8.3, 2.9.x before 2.9.4, 2.10.x before 2.10.2, 2.11.x before 2.11.3, 2.12.x before 2.12.3, and 3.x before 3.0.0.beta.3, as distributed with Ruby on Rails 3.x and 4.x, allow remote attackers to determine the existence of files outside the application root via a ../ (dot dot slash) sequence with (1) double slashes or (2) URL encoding.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-7819?

24 open source packages ship an affected version, including sprockets. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sprockets` | RubyGems | All versions | 2.0.5 |
| `sprockets` | RubyGems | All versions | 2.0.5 |
| `sprockets` | RubyGems | From 2.1.0 | 2.1.4 |
| `sprockets` | RubyGems | From 2.1.0 | 2.1.4 |
| `sprockets` | RubyGems | From 2.10.0 | 2.10.2 |
| `sprockets` | RubyGems | From 2.10.0 | 2.10.2 |
| `sprockets` | RubyGems | From 2.11.0 | 2.11.3 |
| `sprockets` | RubyGems | From 2.11.0 | 2.11.3 |
| `sprockets` | RubyGems | From 2.12.0 | 2.12.3 |
| `sprockets` | RubyGems | From 2.12.0 | 2.12.3 |
| `sprockets` | RubyGems | From 2.2.0 | 2.2.3 |
| `sprockets` | RubyGems | From 2.2.0 | 2.2.3 |
| `sprockets` | RubyGems | From 2.3.0 | 2.3.3 |
| `sprockets` | RubyGems | From 2.3.0 | 2.3.3 |
| `sprockets` | RubyGems | From 2.4.0 | 2.4.6 |
| `sprockets` | RubyGems | From 2.4.0 | 2.4.6 |
| `sprockets` | RubyGems | From 2.5.0 | 2.5.1 |
| `sprockets` | RubyGems | From 2.5.0 | 2.5.1 |
| `sprockets` | RubyGems | From 2.6.0 | 2.7.1 |
| `sprockets` | RubyGems | From 2.6.0 | 2.7.1 |
| `sprockets` | RubyGems | From 2.8.0 | 2.8.3 |
| `sprockets` | RubyGems | From 2.8.0 | 2.8.3 |
| `sprockets` | RubyGems | From 2.9.0 | 2.9.4 |
| `sprockets` | RubyGems | From 2.9.0 | 2.9.4 |

Products: Sprockets Project Sprockets.

## How do I fix CVE-2014-7819?

Upgrade sprockets to a fixed version for your release line: 2.0.5, 2.1.4, 2.10.2 or 2.11.3.

## Is CVE-2014-7819 being exploited?

There is no known exploitation of CVE-2014-7819 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7819 and fix it if it is affected.

What it is: CVE-2014-7819 is a medium-severity path traversal vulnerability in n/a, published on 8 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7819 in the wild and no public exploit code.

Affected packages and fixed versions:
- sprockets (RubyGems): affected all versions; fixed in 2.0.5
- sprockets (RubyGems): affected all versions; fixed in 2.0.5
- sprockets (RubyGems): affected from 2.1.0; fixed in 2.1.4
- sprockets (RubyGems): affected from 2.1.0; fixed in 2.1.4
- sprockets (RubyGems): affected from 2.10.0; fixed in 2.10.2
- sprockets (RubyGems): affected from 2.10.0; fixed in 2.10.2
- sprockets (RubyGems): affected from 2.11.0; fixed in 2.11.3
- sprockets (RubyGems): affected from 2.11.0; fixed in 2.11.3
- sprockets (RubyGems): affected from 2.12.0; fixed in 2.12.3
- sprockets (RubyGems): affected from 2.12.0; fixed in 2.12.3
- sprockets (RubyGems): affected from 2.2.0; fixed in 2.2.3
- sprockets (RubyGems): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7819/ (Markdown: https://insights.sbomify.com/CVE-2014-7819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7819
- OSV: https://osv.dev/vulnerability/CVE-2014-7819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7819/
Summaries are generated and may contain mistakes; the official description above is the record.
