CVE-2014-7829 Directory traversal vulnerability in actionpack
Remote attackers can determine the existence of files outside the application root via directory traversal when static asset serving is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-7829?
CVE-2014-7829 is a medium-severity path traversal vulnerability in Opensuse Opensuse, published on 18 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.21, 4.0.x before 4.0.12, 4.1.x before 4.1.8, and 4.2.x before 4.2.0.beta4, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via vectors involving a \ (backslash) character, a similar issue to CVE-2014-7818.
Weakness: CWE-22
Which versions are affected by CVE-2014-7829?
8 open source packages ship an affected version, including actionpack. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 3.0.0 | 3.2.21 |
actionpack RubyGems | From 3.0.0 | 3.2.21 |
actionpack RubyGems | From 4.0.0 | 4.0.12 |
actionpack RubyGems | From 4.0.0 | 4.0.12 |
actionpack RubyGems | From 4.1.0 | 4.1.8 |
actionpack RubyGems | From 4.1.0 | 4.1.8 |
2 more packages
actionpack RubyGems | From 4.2.0.beta1 | 4.2.0.beta4 |
actionpack RubyGems | From 4.2.0.beta1 | 4.2.0.beta4 |
Products include Opensuse Opensuse, Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2014-7829?
Upgrade actionpack to a fixed version for your release line: 3.2.21, 4.0.12, 4.1.8 or 4.2.0.beta4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2014-7829 being exploited?
There is no known exploitation of CVE-2014-7829 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-7829, GHSA-h56m-vwxc-3qpw.