CVE-2014-7830 Moodle cross-site scripting (XSS) vulnerability
Authenticated users with specific capabilities can inject arbitrary scripts via the searchcourse parameter in Moodle's Feedback module.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-7830?
CVE-2014-7830 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in mod/feedback/mapcourse.php in the Feedback module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the mod/feedback:mapcourse capability to provide a searchcourse parameter.
Weakness: CWE-79
Which versions are affected by CVE-2014-7830?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.5.9 |
moodle/moodle Packagist | All versions | 2.5.9 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-7830?
Upgrade moodle/moodle to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-7830 being exploited?
There is no known exploitation of CVE-2014-7830 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-j4mr-vc54-h5pc.