CVE-2014-7832 Moodle allows attackers to bypass the mod/lti:view capability requirement

Medium 4.0 Published Updated

Authenticated users can bypass view restrictions to access unauthorized LTI activity instances in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-7832?

CVE-2014-7832 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.

Weakness: CWE-264

Which versions are affected by CVE-2014-7832?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.7.02.7.3
moodle/moodle PackagistFrom 2.7.02.7.3

Products include Moodle Moodle.

How do I fix CVE-2014-7832?

Upgrade moodle/moodle to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2014-7832 being exploited?

There is no known exploitation of CVE-2014-7832 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-mphj-h2fc-62x3.

Is CVE-2014-7832 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free