CVE-2014-7834 Moodle does not verify group permissions
Authenticated users can bypass group permission checks to access restricted forum discussions via the web service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-7834?
CVE-2014-7834 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
mod/forum/externallib.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not verify group permissions, which allows remote authenticated users to access a forum via the forum_get_discussions web service.
Weakness: CWE-264
Which versions are affected by CVE-2014-7834?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-7834?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.6 or 2.7.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-7834 being exploited?
There is no known exploitation of CVE-2014-7834 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-557f-2hv4-7jjm.