CVE-2014-7835 Moodle allows attackers to upload files containing JavaScript

Low 2.1 Published Updated

Authenticated users can upload malicious JavaScript files to profile picture areas, enabling cross-site scripting attacks against other users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-7835?

CVE-2014-7835 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure that a file upload is for a private or draft area, which allows remote authenticated users to upload files containing JavaScript, and consequently conduct cross-site scripting (XSS) attacks, by specifying the profile-picture area.

Weakness: CWE-79

Which versions are affected by CVE-2014-7835?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.7.02.7.3
moodle/moodle PackagistFrom 2.7.02.7.3

Products include Moodle Moodle.

How do I fix CVE-2014-7835?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.6 or 2.7.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-7835 being exploited?

There is no known exploitation of CVE-2014-7835 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-vrf6-q7qj-69v5.

Is CVE-2014-7835 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free