# CVE-2014-7835: Moodle allows attackers to upload files containing JavaScript

> Authenticated users can upload malicious JavaScript files to profile picture areas, enabling cross-site scripting attacks against other users.

- **Severity:** Low 2.1 (`AV:N/AC:H/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vrf6-q7qj-69v5

## What is CVE-2014-7835?

CVE-2014-7835 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure that a file upload is for a private or draft area, which allows remote authenticated users to upload files containing JavaScript, and consequently conduct cross-site scripting (XSS) attacks, by specifying the profile-picture area.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-7835?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.6 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.6 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.3 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.3 |

Products: Moodle Moodle.

## How do I fix CVE-2014-7835?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.6 or 2.7.3.

## Is CVE-2014-7835 being exploited?

There is no known exploitation of CVE-2014-7835 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7835 and fix it if it is affected.

What it is: CVE-2014-7835 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-7835 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.6
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.6
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.3
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7835/ (Markdown: https://insights.sbomify.com/CVE-2014-7835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7835
- OSV: https://osv.dev/vulnerability/CVE-2014-7835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7835/
Summaries are generated and may contain mistakes; the official description above is the record.
