CVE-2014-7838 Moodle has multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module

Medium 6.8 Published Updated

Remote attackers can hijack user sessions to modify tracking preferences in Moodle's Forum module via CSRF.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-7838?

CVE-2014-7838 is a medium-severity vulnerability in Moodle Moodle, published on 24 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allow remote attackers to hijack the authentication of arbitrary users for requests that set a tracking preference within (1) mod/forum/deprecatedlib.php, (2) mod/forum/forum.js, (3) mod/forum/index.php, or (4) mod/forum/lib.php.

Weakness: CWE-352

Which versions are affected by CVE-2014-7838?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.7.02.7.3
moodle/moodle PackagistFrom 2.7.02.7.3

Products include Moodle Moodle.

How do I fix CVE-2014-7838?

Upgrade moodle/moodle to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.

Is CVE-2014-7838 being exploited?

There is no known exploitation of CVE-2014-7838 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-43r4-vm25-qm78.

Is CVE-2014-7838 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free