{"answers":{"affected":"2 open source packages ship an affected version, including org.jboss.resteasy:resteasy-jaxrs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-7839 in the wild and no public exploit code.","fix":"Upgrade org.jboss.resteasy:resteasy-jaxrs to 3.0.11.Final or later.","what":"CVE-2014-7839 is a medium-severity vulnerability in n/a, published on 25 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-7839 and fix it if it is affected.\n\nWhat it is: CVE-2014-7839 is a medium-severity vulnerability in n/a, published on 25 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-7839 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jboss.resteasy:resteasy-jaxrs (Maven): affected all versions; fixed in 3.0.11.Final\n- org.jboss.resteasy:resteasy-jaxrs (Maven): affected all versions; fixed in 3.0.11.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-7839/ (Markdown: https://insights.sbomify.com/CVE-2014-7839/index.md)","id":"CVE-2014-7839","markdown":"https://insights.sbomify.com/CVE-2014-7839/index.md","name":"CVE-2014-7839","record":{"aliases":["GHSA-pc54-pchm-xcw6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java REST library","requires_auth":"none","summary":"Remote attackers can exploit XML External Entity vulnerabilities in RESTEasy to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"resteasy","vendor":"redhat"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"DocumentProvider in RESTEasy 2.3.7 and 3.0.9 does not configure the (1) external-general-entities or (2) external-parameter-entities features, which allows remote attackers to conduct XML external entity (XXE) attacks via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XML External Entity Reference in RESTEasy","id":"CVE-2014-7839","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2014-7840"},"packages":[{"ecosystem":"Maven","fixed":["3.0.11.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.resteasy:resteasy-jaxrs","purl":null,"source":"GHSA-pc54-pchm-xcw6"},{"ecosystem":"Maven","fixed":["3.0.11.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.resteasy:resteasy-jaxrs","purl":"pkg:maven/org.jboss.resteasy/resteasy-jaxrs","source":"GHSA-pc54-pchm-xcw6"}],"prev":{"headline":"Moodle has multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module","id":"CVE-2014-7838"},"products":["n/a"],"published":"2014-11-25","related":[{"cvss_score":8.1,"headline":"JBoss RESTEasy vulnerable to Improper Input Validation","id":"CVE-2016-9606","kev_date_added":null,"published":"2018-03-09"},{"cvss_score":8.1,"headline":"Deserialization of Untrusted Data in org.jboss.resteasy:resteasy-yaml-provider","id":"CVE-2018-1051","kev_date_added":null,"published":"2018-01-25"},{"cvss_score":7.5,"headline":"Denial of service in JBoss resteasy","id":"CVE-2016-6346","kev_date_added":null,"published":"2016-09-07"},{"cvss_score":6.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in RESTEasy","id":"CVE-2016-6345","kev_date_added":null,"published":"2016-09-07"},{"cvss_score":6.1,"headline":"Improper Neutralization of Input During Web Page Generation in RESTEasy","id":"CVE-2016-6347","kev_date_added":null,"published":"2017-04-20"},{"cvss_score":6.1,"headline":"JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack","id":"CVE-2016-6348","kev_date_added":null,"published":"2017-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit XML External Entity vulnerabilities in RESTEasy to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2014-7839/"}