CVE-2014-7847 Moodle allows attackers to cause a denial of service

Medium 5.0 Published Updated

Remote attackers can cause denial of service in Moodle by triggering resource-intensive IP geolocation calculations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-7847?

CVE-2014-7847 is a medium-severity denial of service vulnerability in Moodle Moodle, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

iplookup/index.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote attackers to cause a denial of service (resource consumption) by triggering the calculation of an estimated latitude and longitude for an IP address.

Weakness: CWE-399

Which versions are affected by CVE-2014-7847?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistAll versions2.5.9
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.6.02.6.6
moodle/moodle PackagistFrom 2.7.02.7.3
moodle/moodle PackagistFrom 2.7.02.7.3

Products include Moodle Moodle.

How do I fix CVE-2014-7847?

Upgrade moodle/moodle to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2014-7847 being exploited?

There is no known exploitation of CVE-2014-7847 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-6vjg-2q57-rgfw.

Is CVE-2014-7847 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free