CVE-2014-7848 Moodle allows attacks to obtain sensitive information
Remote attackers can obtain sensitive full path information via direct requests to a specific PHP file in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-7848?
CVE-2014-7848 is a medium-severity vulnerability in Moodle Moodle, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
lib/phpunit/bootstrap.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 allows remote attackers to obtain sensitive information via a direct request, which reveals the full path in an error message.
Weakness: CWE-200
Which versions are affected by CVE-2014-7848?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-7848?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.6 or 2.7.3.
Is CVE-2014-7848 being exploited?
There is no known exploitation of CVE-2014-7848 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-47cw-whh9-j2fq.