# CVE-2014-7848: Moodle allows attacks to obtain sensitive information

> Remote attackers can obtain sensitive full path information via direct requests to a specific PHP file in Moodle.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-47cw-whh9-j2fq

## What is CVE-2014-7848?

CVE-2014-7848 is a medium-severity vulnerability in Moodle Moodle, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/phpunit/bootstrap.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 allows remote attackers to obtain sensitive information via a direct request, which reveals the full path in an error message.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-7848?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.6 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.6 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.3 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.3 |

Products: Moodle Moodle.

## How do I fix CVE-2014-7848?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.6 or 2.7.3.

## Is CVE-2014-7848 being exploited?

There is no known exploitation of CVE-2014-7848 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7848 and fix it if it is affected.

What it is: CVE-2014-7848 is a medium-severity vulnerability in Moodle Moodle, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7848 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.6
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.6
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.3
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7848/ (Markdown: https://insights.sbomify.com/CVE-2014-7848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7848
- OSV: https://osv.dev/vulnerability/CVE-2014-7848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7848/
Summaries are generated and may contain mistakes; the official description above is the record.
