# CVE-2014-7960: OpenStack Swift metadata constraints are not correctly enforced

> Authenticated users can bypass metadata count limits in OpenStack Swift by sending multiple crafted requests, violating resource constraints.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-7960, GHSA-g6x3-55qv-x6p2, PYSEC-2026-933, RHSA-2015:0835, RHSA-2015:0836, UBUNTU-CVE-2014-7960

## What is CVE-2014-7960?

CVE-2014-7960 is a medium-severity vulnerability in n/a, published on 17 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Object Storage (Swift) before 2.2.0 allows remote authenticated users to bypass the max_meta_count and other metadata constraints via multiple crafted requests which exceed the limit when combined.

Weakness: CWE-399

## Which versions are affected by CVE-2014-7960?

3 open source packages ship an affected version, including swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 2.2.0 |
| `swift` | PyPI | All versions | 2.2.0 |
| `swift` | PyPI | All versions | 2.2.0 |
| `openstack-swift` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift-account` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift-container` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift-doc` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift-object` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift-proxy` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-4.el6ost |
| `openstack-swift` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |
| `openstack-swift-account` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |
| `openstack-swift-container` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |
| `openstack-swift-doc` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |
| `openstack-swift-object` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |
| `openstack-swift-proxy` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-4.el7ost |

Products: Openstack Swift.

## How do I fix CVE-2014-7960?

Upgrade swift to 2.2.0 or later.

## Is CVE-2014-7960 being exploited?

There is no known exploitation of CVE-2014-7960 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-0737](https://insights.sbomify.com/CVE-2016-0737/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2016-0738](https://insights.sbomify.com/CVE-2016-0738/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2026-49017](https://insights.sbomify.com/CVE-2026-49017/): OpenStack Swift: s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request body (high 7.1)
- [CVE-2013-6396](https://insights.sbomify.com/CVE-2013-6396/): Python Swift client is vulnerable to Missing SSL Certificate Check (medium 5.8)
- [CVE-2026-50221](https://insights.sbomify.com/CVE-2026-50221/): OpenStack Swift vulnerable to authenticated server-side request forgery (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-7960 and fix it if it is affected.

What it is: CVE-2014-7960 is a medium-severity vulnerability in n/a, published on 17 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-7960 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 2.2.0
- swift (PyPI): affected all versions; fixed in 2.2.0
- swift (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-7960/ (Markdown: https://insights.sbomify.com/CVE-2014-7960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-7960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-7960
- OSV: https://osv.dev/vulnerability/CVE-2014-7960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-7960/
Summaries are generated and may contain mistakes; the official description above is the record.
