CVE-2014-8088 Zend Access Restriction Bypass
Remote attackers can bypass authentication in Zend Framework LDAP components by using a null byte in the password, leading to unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-8088?
CVE-2014-8088 is a medium-severity authentication bypass vulnerability in n/a, published on 22 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.
Weakness: CWE-287
Which versions are affected by CVE-2014-8088?
10 open source packages ship an affected version, including zendframework/zendframework and zendframework/zendframework1. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zendframework/zendframework Packagist | From 2.0.0 | 2.0.99 |
zendframework/zendframework Packagist | From 2.0.0 | 2.0.99 |
zendframework/zendframework Packagist | From 2.1.0 | 2.1.99 |
zendframework/zendframework Packagist | From 2.1.0 | 2.1.99 |
zendframework/zendframework Packagist | From 2.2.0 | 2.2.8 |
zendframework/zendframework Packagist | From 2.2.0 | 2.2.8 |
4 more packages
zendframework/zendframework Packagist | From 2.3.0 | 2.3.3 |
zendframework/zendframework Packagist | From 2.3.0 | 2.3.3 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.9 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.9 |
Products include Zend Zend Framework.
How do I fix CVE-2014-8088?
Upgrade zendframework/zendframework to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.8 or 2.3.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2014-8088 being exploited?
There is no known exploitation of CVE-2014-8088 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-f6rc-rh43-h8gr, UBUNTU-CVE-2014-8088.