# CVE-2014-8088: Zend Access Restriction Bypass

> Remote attackers can bypass authentication in Zend Framework LDAP components by using a null byte in the password, leading to unauthorized access.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f6rc-rh43-h8gr, UBUNTU-CVE-2014-8088

## What is CVE-2014-8088?

CVE-2014-8088 is a medium-severity authentication bypass vulnerability in n/a, published on 22 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2014-8088?

10 open source packages ship an affected version, including zendframework/zendframework and zendframework/zendframework1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zendframework` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zendframework` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zendframework` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zendframework` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.9 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.9 |

Products: Zend Zend Framework.

## How do I fix CVE-2014-8088?

Upgrade zendframework/zendframework to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.8 or 2.3.3.

## Is CVE-2014-8088 being exploited?

There is no known exploitation of CVE-2014-8088 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-29312](https://insights.sbomify.com/CVE-2020-29312/): Deserialization in n/a (critical 9.8)
- [CVE-2015-1555](https://insights.sbomify.com/CVE-2015-1555/): Auth bypass in n/a (critical 9.1)
- [CVE-2015-1786](https://insights.sbomify.com/CVE-2015-1786/): Zend Framework CSRF Vulnerability (high 8.8)
- [CVE-2015-7503](https://insights.sbomify.com/CVE-2015-7503/): Zend Framework Information Disclosure (high 7.5)
- [CVE-2014-2685](https://insights.sbomify.com/CVE-2014-2685/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8088 and fix it if it is affected.

What it is: CVE-2014-8088 is a medium-severity authentication bypass vulnerability in n/a, published on 22 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8088 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zendframework (Packagist): affected from 2.1.0; fixed in 2.1.99
- zendframework/zendframework (Packagist): affected from 2.1.0; fixed in 2.1.99
- zendframework/zendframework (Packagist): affected from 2.2.0; fixed in 2.2.8
- zendframework/zendframework (Packagist): affected from 2.2.0; fixed in 2.2.8
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.3
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.3
- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.9
- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8088/ (Markdown: https://insights.sbomify.com/CVE-2014-8088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8088
- OSV: https://osv.dev/vulnerability/CVE-2014-8088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8088/
Summaries are generated and may contain mistakes; the official description above is the record.
