CVE-2014-8089 Zend Framework SQL injection vulnerability
Remote attackers can execute arbitrary SQL commands in Zend Framework applications using the sqlsrv extension via null byte injection.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-8089?
CVE-2014-8089 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 17 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.
Weakness: CWE-89
Which versions are affected by CVE-2014-8089?
18 open source packages ship an affected version, including zendframework/zend-db, zendframework/zendframework and zendframework/zendframework1. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
zendframework/zend-db Packagist | From 2.0.0 | 2.0.99 |
zendframework/zend-db Packagist | From 2.0.0 | 2.0.99 |
zendframework/zend-db Packagist | From 2.1.0 | 2.1.99 |
zendframework/zend-db Packagist | From 2.1.0 | 2.1.99 |
zendframework/zend-db Packagist | From 2.2.0 | 2.2.8 |
zendframework/zend-db Packagist | From 2.2.0 | 2.2.8 |
12 more packages
zendframework/zend-db Packagist | From 2.3.0 | 2.3.3 |
zendframework/zend-db Packagist | From 2.3.0 | 2.3.3 |
zendframework/zendframework Packagist | From 2.0.0 | 2.0.99 |
zendframework/zendframework Packagist | From 2.0.0 | 2.0.99 |
zendframework/zendframework Packagist | From 2.1.0 | 2.1.99 |
zendframework/zendframework Packagist | From 2.1.0 | 2.1.99 |
zendframework/zendframework Packagist | From 2.2.0 | 2.2.8 |
zendframework/zendframework Packagist | From 2.2.0 | 2.2.8 |
zendframework/zendframework Packagist | From 2.3.0 | 2.3.3 |
zendframework/zendframework Packagist | From 2.3.0 | 2.3.3 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.9 |
zendframework/zendframework1 Packagist | From 1.12.0 | 1.12.9 |
Products include Fedoraproject Fedora, Redhat Enterprise Linux, Zend Zend Framework.
How do I fix CVE-2014-8089?
Upgrade zendframework/zend-db to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.8 or 2.3.3.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2014-8089 being exploited?
There is no known exploitation of CVE-2014-8089 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-qh9w-r7g5-q939, UBUNTU-CVE-2014-8089.