# CVE-2014-8089: Zend Framework SQL injection vulnerability

> Remote attackers can execute arbitrary SQL commands in Zend Framework applications using the sqlsrv extension via null byte injection.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qh9w-r7g5-q939, UBUNTU-CVE-2014-8089

## What is CVE-2014-8089?

CVE-2014-8089 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 17 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-8089?

18 open source packages ship an affected version, including zendframework/zend-db, zendframework/zendframework and zendframework/zendframework1. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zend-db` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zend-db` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zend-db` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zend-db` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zend-db` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zend-db` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zend-db` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zend-db` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.0.99 |
| `zendframework/zendframework` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zendframework` | Packagist | From 2.1.0 | 2.1.99 |
| `zendframework/zendframework` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zendframework` | Packagist | From 2.2.0 | 2.2.8 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.3 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.9 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.9 |

Products: Fedoraproject Fedora, Redhat Enterprise Linux, Zend Zend Framework.

## How do I fix CVE-2014-8089?

Upgrade zendframework/zend-db to a fixed version for your release line: 2.0.99, 2.1.99, 2.2.8 or 2.3.3.

## Is CVE-2014-8089 being exploited?

There is no known exploitation of CVE-2014-8089 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8089 and fix it if it is affected.

What it is: CVE-2014-8089 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 17 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8089 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zend-db (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zend-db (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zend-db (Packagist): affected from 2.1.0; fixed in 2.1.99
- zendframework/zend-db (Packagist): affected from 2.1.0; fixed in 2.1.99
- zendframework/zend-db (Packagist): affected from 2.2.0; fixed in 2.2.8
- zendframework/zend-db (Packagist): affected from 2.2.0; fixed in 2.2.8
- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.3
- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.3
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.0.99
- zendframework/zendframework (Packagist): affected from 2.1.0; fixed in 2.1.99
- zendframework/zendframework (Packagist): affected from 2.1.0; fixed in 2.1.99

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8089/ (Markdown: https://insights.sbomify.com/CVE-2014-8089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8089
- OSV: https://osv.dev/vulnerability/CVE-2014-8089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8089/
Summaries are generated and may contain mistakes; the official description above is the record.
